import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\s]*b[^\\s]*a[^\\s]*d[^\\s]*w[^\\s]*o[^\\s]*r[^\\s]*d[^\\s]*";
final String string = "i'm a badword and test it\n"
+ "tebstadword not ?\n"
+ "What aboua{d|wo}rd ?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}