using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(0098|\+98|98|0|)(9\d{9}$)";
string input = @"00989123456789
+989123456789
989123456789
09123456789
9123456789
321351321321
+98913131532
sad00989123456789
00989123456789abc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}