use strict;
my $str = '00989123456789
+989123456789
989123456789
09123456789
9123456789
321351321321
+98913131532
sad00989123456789
00989123456789abc';
my $regex = qr/^(0098|\+98|98|0|)(9\d{9}$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}