// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(0098|\+98|98|0|)(9\d{9}$)").unwrap();
let string = "00989123456789
+989123456789
989123456789
09123456789
9123456789
321351321321
+98913131532
sad00989123456789
00989123456789abc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}