const regex = /^(.{6}|.{15})657/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.{6}|.{15})657', 'gm')
const str = `0000000000657
00000000000008165736
RF77706578000000000543278`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}