re = /^(.{6}|.{15})657/m
str = '0000000000657
00000000000008165736
RF77706578000000000543278'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end