import re
regex = re.compile(r"^(.{6}|.{15})657", flags=re.MULTILINE)
test_str = ("0000000000657\n"
"00000000000008165736\n"
"RF77706578000000000543278")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")