package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$\{\s*isset ([a-zA-Z]*) \s*\}(.*)\$\{\s*end\s*\}`)
var str = `${isset foo }xxx${end}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}