$re = '/\$\{\s*isset ([a-zA-Z]*) \s*\}(.*)\$\{\s*end\s*\}/m';
$str = '${isset foo }xxx${end}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);