re = /\$\{\s*isset ([a-zA-Z]*) \s*\}(.*)\$\{\s*end\s*\}/m
str = '${isset foo }xxx${end}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end