#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+)\/\w+(?<=\/item)(\/(\w+)\/)?"
Local $sString = "/test/v1/3908643GASF/item" & @CRLF & _
"/test/v1/343569/item/AAAS45663/document" & @CRLF & _
"/test/v2/field/1230FRE/item"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")