$re = '/(\w+)\/\w+(?<=\/item)(\/(\w+)\/)?/m';
$str = '/test/v1/3908643GASF/item
/test/v1/343569/item/AAAS45663/document
/test/v2/field/1230FRE/item';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);