import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)\\/\\w+(?<=\\/item)(\\/(\\w+)\\/)?";
final String string = "/test/v1/3908643GASF/item\n"
+ "/test/v1/343569/item/AAAS45663/document\n"
+ "/test/v2/field/1230FRE/item";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}