using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^new_timer/\?(?P<params>[^/]+)$";
string input = @"new_timer/?UID=046F1572564080&runtime=1102&seconds=30stillrunning=1&numstoredtimes=3&storedtimes=13:2-23:32-48:43&checksum=71";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}