re = /^new_timer\/\?(?P<params>[^\/]+)$/m
str = 'new_timer/?UID=046F1572564080&runtime=1102&seconds=30stillrunning=1&numstoredtimes=3&storedtimes=13:2-23:32-48:43&checksum=71'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end