package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^new_timer/\?(?P<params>[^/]+)$`)
var str = `new_timer/?UID=046F1572564080&runtime=1102&seconds=30stillrunning=1&numstoredtimes=3&storedtimes=13:2-23:32-48:43&checksum=71`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}