using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\d\s,/]+)(?<num>\d+)([,/-])(?<num>\d+)(?:\2(?<num>\d+))*(?!\S)";
string input = @"Number1,2,3 or Number4/5/6 but not Number4/5,6";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}