$re = '/([^\d\s,/]+)(?<num>\d+)([,/-])(?<num>\d+)(?:\2(?<num>\d+))*(?!\S)/m';
$str = 'Number1,2,3 or Number4/5/6 but not Number4/5,6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);