re = /([^\d\s,\/]+)(?<num>\d+)([,\/-])(?<num>\d+)(?:\2(?<num>\d+))*(?!\S)/m
str = 'Number1,2,3 or Number4/5/6 but not Number4/5,6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end