#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(?:^|,|\r?\n)[^\S\r\n]*)(?:("[^"\\]*(?:\\[\S\s][^"\\]*)*"|'[^'\\]*(?:\\[\S\s][^'\\]*)*'|[^,\r\n]*)(?:[^\S\r\n]*(?=$|,|\r?\n)))"
Local $sString = "hello, '{"an object" : [{"sub-object 1": {" & @CRLF & _
" "description": "sub-object is for blah blah"," & @CRLF & _
" "nestedArray": ["param1","param2","param3"]}}," & @CRLF & _
" {"sub-object 2": {" & @CRLF & _
" "description": "sub-object is for blah blah"," & @CRLF & _
" "nestedArray": ["param1","param2","param3"]}}," & @CRLF & _
" {"sub-object 3": {" & @CRLF & _
" "description": "sub-object is for blah blah"," & @CRLF & _
" "nestedArray": ["param1","param2","param3"]}}" & @CRLF & _
" ]" & @CRLF & _
"}', Howdy, " The end""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")