const regex = /(?:(?:^|,|\r?\n)[^\S\r\n]*)(?:("[^"\\]*(?:\\[\S\s][^"\\]*)*"|'[^'\\]*(?:\\[\S\s][^'\\]*)*'|[^,\r\n]*)(?:[^\S\r\n]*(?=$|,|\r?\n)))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:^|,|\\r?\\n)[^\\S\\r\\n]*)(?:("[^"\\\\]*(?:\\\\[\\S\\s][^"\\\\]*)*"|\'[^\'\\\\]*(?:\\\\[\\S\\s][^\'\\\\]*)*\'|[^,\\r\\n]*)(?:[^\\S\\r\\n]*(?=$|,|\\r?\\n)))', 'g')
const str = `hello, '{"an object" : [{"sub-object 1": {
"description": "sub-object is for blah blah",
"nestedArray": ["param1","param2","param3"]}},
{"sub-object 2": {
"description": "sub-object is for blah blah",
"nestedArray": ["param1","param2","param3"]}},
{"sub-object 3": {
"description": "sub-object is for blah blah",
"nestedArray": ["param1","param2","param3"]}}
]
}', Howdy, " The end"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}