import Foundation
let pattern = #"(?:(?:^|,|\r?\n)[^\S\r\n]*)(?:("[^"\\]*(?:\\[\S\s][^"\\]*)*"|'[^'\\]*(?:\\[\S\s][^'\\]*)*'|[^,\r\n]*)(?:[^\S\r\n]*(?=$|,|\r?\n)))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
hello, '{"an object" : [{"sub-object 1": {
"description": "sub-object is for blah blah",
"nestedArray": ["param1","param2","param3"]}},
{"sub-object 2": {
"description": "sub-object is for blah blah",
"nestedArray": ["param1","param2","param3"]}},
{"sub-object 3": {
"description": "sub-object is for blah blah",
"nestedArray": ["param1","param2","param3"]}}
]
}', Howdy, " The end"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)