import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*(?P<gender>\\b(?:fe)?male\\b))?(?=.*(?P<quality>\\b(?:green|amber|red)\\b))?(?=.*(?P<feedback>\\b(?:positive|negative)\\b))?.*";
final String string = "female green\n"
+ "positive male\n"
+ " positive female\n"
+ "female bad\n"
+ "male average\n"
+ "male\n"
+ " female\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}