re = /^(?=.*(?P<gender>\b(?:fe)?male\b))?(?=.*(?P<quality>\b(?:green|amber|red)\b))?(?=.*(?P<feedback>\b(?:positive|negative)\b))?.*/m
str = 'female green
positive male
positive female
female bad
male average
male
female
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end