const regex = /(?s)<tag>(?:<\/tag>(*SKIP)(*FAIL)|.)*?ABC.*?<\/tag>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)<tag>(?:<\\\/tag>(*SKIP)(*FAIL)|.)*?ABC.*?<\\\/tag>', 'g')
const str = `...<tag>a a.__aABC&*</tag>aaa<tag>ffff</tag>...
but not outside (false-positive):
...<tag>a a.__a&*</tag>ABC<tag>ffff</tag>...
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}