re = /(?s)<tag>(?:<\/tag>(*SKIP)(*FAIL)|.)*?ABC.*?<\/tag>/
str = '...<tag>a a.__aABC&*</tag>aaa<tag>ffff</tag>...
but not outside (false-positive):
...<tag>a a.__a&*</tag>ABC<tag>ffff</tag>...
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end