import re
regex = re.compile(r"(?s)<tag>(?:<\/tag>(*SKIP)(*FAIL)|.)*?ABC.*?<\/tag>")
test_str = ("...<tag>a a.__aABC&*</tag>aaa<tag>ffff</tag>...\n\n"
"but not outside (false-positive):\n"
"...<tag>a a.__a&*</tag>ABC<tag>ffff</tag>...\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")