package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[0-9]{5}-1\b`)
var str = `asdasdasd
lorem ipsum
lorem 12345-1
more lorem ipsum bacon`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}