re = /\b[0-9]{5}-1\b/
str = 'asdasdasd
lorem ipsum
lorem 12345-1
more lorem ipsum bacon'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end