$re = '/\b[0-9]{5}-1\b/';
$str = 'asdasdasd
lorem ipsum
lorem 12345-1
more lorem ipsum bacon';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);