import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\"])(?:(?!\\1|\"\").|\"\".)*\\1";
final String string = "Hello Colm \"This is a test\"\"\\\\\"\n"
+ "\"This is also an NL test\"\n"
+ "'And this has an escaped quote don\\'t in it ' Blue Boy\n"
+ "\"This has a single quote ' but doesn\\' end the quote as it started with double quotes\"\n\n"
+ "\"\"\"line spanning with escaped quote at the end of a line\"\"\"\n\n"
+ "\"\"\"\"\n\n"
+ "\"Foo Bar\" \"Another Value\" something else";
final String subst = "Subbed";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}