re = /#(?=(?:[^"'`]*"[^"'`]*")*(?:[^"'`]*'[^"'`]*')*(?:[^"'`]*`[^"'`]*`)*[^"'`]*$)/im
str = ' #somecomment
# some comment
"#not a commnet" #another comment
\'#not a comment\'
jquery_code = "$(\'#some-identifier\')[0].click()"#yet a comment, but the identifier :(
jquery_code = \'$("#some-identifier")[0].click()\'
# just another comment
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end