package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+(:?-\w+)*`)
var str = `word
word-hyphen
word-hyphen-again
word-hyphen-again-new-beats-me
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}