re = /\w+(:?-\w+)*/
str = 'word
word-hyphen
word-hyphen-again
word-hyphen-again-new-beats-me
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end