$re = '/\w+(:?-\w+)*/';
$str = 'word
word-hyphen
word-hyphen-again
word-hyphen-again-new-beats-me
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);