#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^New: .* Category: .* (.*) Size: (.*) Seeders: .+ Leechers: .+" & @CRLF & _
"" & @CRLF & _
"^Link: (https://?.*/).*torrentid=(\d+)" & @CRLF & _
"" & @CRLF & _
"^Release: (.*)"
Local $sString = "New: (מה שקורה בצללים - עונה 4, פרק 3 / What We Do in the Shadows - S04E03 *היידפנישן*) Category: סדרות - HD Size: 825.43 MiB Seeders: 0 Leechers: 0" & @CRLF & _
"" & @CRLF & _
"Link: https://hebits.net/torrents.php?torrentid=80081" & @CRLF & _
"" & @CRLF & _
"Release: What.We.Do.in.the.Shadows.S04E03.The.Grand.Opening.720p.AMZN.WEB.DL.DDP5.1.H.264-FLUX"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")