package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^New: .* Category: .* (.*) Size: (.*) Seeders: .+ Leechers: .+
^Link: (https://?.*/).*torrentid=(\d+)
^Release: (.*)`)
var str = `New: (מה שקורה בצללים - עונה 4, פרק 3 / What We Do in the Shadows - S04E03 *היידפנישן*) Category: סדרות - HD Size: 825.43 MiB Seeders: 0 Leechers: 0
Link: https://hebits.net/torrents.php?torrentid=80081
Release: What.We.Do.in.the.Shadows.S04E03.The.Grand.Opening.720p.AMZN.WEB.DL.DDP5.1.H.264-FLUX`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}