using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^New: .* Category: .* (.*) Size: (.*) Seeders: .+ Leechers: .+
^Link: (https://?.*/).*torrentid=(\d+)
^Release: (.*)";
string input = @"New: (מה שקורה בצללים - עונה 4, פרק 3 / What We Do in the Shadows - S04E03 *היידפנישן*) Category: סדרות - HD Size: 825.43 MiB Seeders: 0 Leechers: 0
Link: https://hebits.net/torrents.php?torrentid=80081
Release: What.We.Do.in.the.Shadows.S04E03.The.Grand.Opening.720p.AMZN.WEB.DL.DDP5.1.H.264-FLUX";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}