using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"do this\r?\n\tdont do this";
string input = @"Function {
Do this
Dont do this
}";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}