$re = '/do this\r?\n\tdont do this/i';
$str = 'Function {
Do this
Dont do this
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);