package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)do this\r?\n\tdont do this`)
var str = `Function {
Do this
Dont do this
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}