const regex = new RegExp('\\[(?!;;)([^][]*)]', 'gm')
const str = ` This is a [;;Text] and I want to match [center]everything without ;;[/center]`;
const subst = `<$1>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);