re = /\[(?!;;)([^][]*)]/m
str = ' This is a [;;Text] and I want to match [center]everything without ;;[/center]'
subst = '<$1>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result