use strict;
my $str = ' This is a [;;Text] and I want to match [center]everything without ;;[/center]';
my $regex = qr`\[(?!;;)([^][]*)]`mp;
my $subst = '<$1>';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";