const regex = /(?=[^])(?:\P{Sentence_Terminal}|\p{Sentence_Terminal}(?!['"`\p{Close_Punctuation}\p{Final_Punctuation}\s]))*(?:\p{Sentence_Terminal}+['"`\p{Close_Punctuation}\p{Final_Punctuation}]*|$)/guy;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=[^])(?:\\P{Sentence_Terminal}|\\p{Sentence_Terminal}(?![\'"`\\p{Close_Punctuation}\\p{Final_Punctuation}\\s]))*(?:\\p{Sentence_Terminal}+[\'"`\\p{Close_Punctuation}\\p{Final_Punctuation}]*|$)', 'guy')
const str = `This is a sentence. This is another sentence.
df! bar. qolh "foo."
This is a malformed sentence ending."another sentence starts.
This is MyEnum.Value1. lol!. ........ . . .eeeend
. . .eeeend`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}