$re = '/(?=[^])(?:\P{Sentence_Terminal}|\p{Sentence_Terminal}(?![\'"`\p{Close_Punctuation}\p{Final_Punctuation}\s]))*(?:\p{Sentence_Terminal}+[\'"`\p{Close_Punctuation}\p{Final_Punctuation}]*|$)/uy';
$str = 'This is a sentence. This is another sentence.
df! bar. qolh "foo."
This is a malformed sentence ending."another sentence starts.
This is MyEnum.Value1. lol!. ........ . . .eeeend
. . .eeeend';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);