#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\/system.\/sensor\d\d.+DeviceID=(?P<sensor>[^\n]*).*CurrentReading=(?P<reading>[^\n]*).*SensorType=(?P<type>[^\n]*).*HealthState=(?P<health>[^\n]*).*"
Local $sString = "/system1/sensor37" & @CRLF & _
" Targets" & @CRLF & _
" Properties" & @CRLF & _
" DeviceID=37-Fuse " & @CRLF & _
" ElementName=Power Supply" & @CRLF & _
" OperationalStatus=Ok" & @CRLF & _
" RateUnits=Celsius" & @CRLF & _
" CurrentReading=49" & @CRLF & _
" SensorType=Temperature" & @CRLF & _
" HealthState=Ok" & @CRLF & _
" oemhp_CautionValue=100" & @CRLF & _
" oemhp_CriticalValue=Not Applicable" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")