# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)\/system.\/sensor\d\d.+DeviceID=(?P<sensor>[^\n]*).*CurrentReading=(?P<reading>[^\n]*).*SensorType=(?P<type>[^\n]*).*HealthState=(?P<health>[^\n]*).*"
test_str = ("/system1/sensor37\n"
" Targets\n"
" Properties\n"
" DeviceID=37-Fuse \n"
" ElementName=Power Supply\n"
" OperationalStatus=Ok\n"
" RateUnits=Celsius\n"
" CurrentReading=49\n"
" SensorType=Temperature\n"
" HealthState=Ok\n"
" oemhp_CautionValue=100\n"
" oemhp_CriticalValue=Not Applicable\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.