import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\/system.\\/sensor\\d\\d.+DeviceID=(?P<sensor>[^\\n]*).*CurrentReading=(?P<reading>[^\\n]*).*SensorType=(?P<type>[^\\n]*).*HealthState=(?P<health>[^\\n]*).*";
final String string = "/system1/sensor37\n"
+ " Targets\n"
+ " Properties\n"
+ " DeviceID=37-Fuse \n"
+ " ElementName=Power Supply\n"
+ " OperationalStatus=Ok\n"
+ " RateUnits=Celsius\n"
+ " CurrentReading=49\n"
+ " SensorType=Temperature\n"
+ " HealthState=Ok\n"
+ " oemhp_CautionValue=100\n"
+ " oemhp_CriticalValue=Not Applicable\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}