#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)^(?!$)\s+|\s+(?<!^)$|(?<=\?).*|(.)\1*(?=\1{2})|[^-\w\s.?]|\b(?<!['-])((?:['\w-])+)\b(?=\W+\2)\s*"
Local $sString = " Well well well well, let's seeeeee what what the the ===^&the %$#@!the the 500006 edition boook has has## to #say #$%^&- <_______about___> this_thing? None of your business!" & @CRLF & _
"" & @CRLF & _
" spaces removed "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)